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GEO 827  Digital Image Processing and Analysis 
 
Exercise 9a.  Training Signature Selection and Supervised Classification              

using the Maximum Likelihood and SAM Algorithms  
 
This exercise builds upon your previous lab experiences. You should be familiar with the 
Display, Spectral Profiling and Contrast Enhancement tools in ERDAS Imagine. The objectives 
of this exercise are to develop/reinforce your knowledge of: 
 

 The training site delineation (AOI) tools in ERDAS Imagine 
 The Signature Editor tool in ERDAS Imagine 
 The signature evaluation tool (Image Alarm) in ERDAS Imagine 
 The classification evaluation tools in ERDAS (Swipe tool and Thresholding) 
 

Training Signature Collection  
 

1.  Copy the Data/Lab 9 folder on DropBox to your personal folder on the server. 
 
2. Start ERDAS Imagine 2014. Right-mouse-button click on the “2D View #1” layer in the 

“Contents” widow and select Open Raster Layer from the pop-up menu. Navigate to your 
personal folder on the server, select the file named “lansing_sub.img” and click OK.   
 

3. Using the Layer Combination tool from the Multispectral tab, change the band 
combinations in “2D View #1” to display a 5,4,3 SWIR false-color image. Contrast stretch 
this image to your liking for maximum interpretability.  

 
OPTIONAL - If you desire, open a second viewer and display the same image file 
(lansing_sub.img) as a 4,3,2 CIR false-color or 3,2,1 true-color composite. If you choose 
this option, GeoLink the two viewers. 

 
4. From the Raster tab on the ribbon tool bar, click on the Supervised button and select 

Signature Editor from the drop-down menu. After a few moments, the Signature Editor 
Window (SEW) will open.  Resize the SEW, if necessary, to see all the functions and 
familiarize yourself with the function icons available in the window using the cursor rollover 
feature (i.e., when you put the cursor on top of each icon, a function description line will 
display in the bottom-left of the SEW). 
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Your assignment is to create at least three signatures for each of the 
following eight land cover / use types (you will use these signatures to classify the 
image): 
 

 Urban, high intensity (commercial, industrial and transportation combined) 
 Urban, low intensity (residential) 
 Broadleaf forests (upland and lowland, combined) 
 Green herbaceous (crops/hay/turf grass, combined) 
 Bare mineral soils, moist and/or high organic matter content 
 Bare mineral soils, dry and/or low organic matter content 
 Bare organic soils 
 Water (rivers, lakes and ponds, combined) 

 
 

5. In the “2D View #1” viewer, zoom in on a type-example of one of the land cover/use types 
listed above. Click the Drawing tab in the ribbon tool bar and select the Polygon tool from 
within the Insert Geometry tool group. Use the polygon drawing tool to delineate an area of 
interest (AOI) in the “lansing_sub.img” image in the “2D View #1” viewer (the 5,4,3 false-
color composite). 

 
In the “2D View #1” viewer, start to left-click a polygon outline of the land cover/use type 
you zoomed in to (be careful to avoid the edge, i.e., mixed pixels). To close the AOI 
polygon, double left-click without moving your cursor.  Make sure you “stop short” of your 
“point of beginning”, since the double left-click action will automatically snap a closing arc 
between the cursor location and the point of beginning.   
 
A white dotted polygon will be drawn around the area you just “digitized”.  If you are not 
satisfied with the result, you can erase the AOI by selecting it (the editing box will appear 
around the AOI polygon) using the Select pointer tool and then click on Delete button in the 
Edit tool group of the Drawing tab or just use the Delete button on your computer keyboard. 
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6. Once you have outlined a group of pixels that are representative of the cover type of interest, 
come back to the Signature Editor window and click on the “Create New Signature(s) from 
AOI” icon.  A new signature called “class1” will be entered in the window, with information 
associated with the training site you just selected.  

 
 
 
 
 
 
 
 
 
 

 

Change the name of the training site from “class1” to an appropriate land cover/use name 
(e.g., “water1”) and change the color of the signature class to Yellow (temporary color 
assignment to facilitate the Image Alarm function) by left-clicking on the color box and 
selecting yellow from the palette that appears. 

 
 
 
 
 
 
 
 
 
 
 
 
 

 
 

7. Evaluate the new training site using the Image Alarm function selected from the Signature 
Editor tool bar (View Image Alarm).  In the Signature Alarm dialog box that opens, 
press the “Edit Parallelepiped Limits…” button.  At the bottom of the new window that 
opens, press the “Set…” button.  We will use standard deviation boundaries (not 
“Minimum/Maximum”) to establish our parallelepiped decision space in order to avoid 
outliers in the training data.  Set the Parallelepiped Limits to “2.00 Standard Deviations” (2 
standard deviations encompasses 95.4% of the distribution of pixel values in the training set).  
Press the “OK” button at the bottom-left of the Set Parallelepiped Limits box.  Close both 
the “Set Parallelepiped Limits” and “Limits” windows, but LEAVE THE “SIGNATURE 
ALARM” WINDOW OPEN (you will use it again and again). 

Rename the class 

Change color to Yellow for  
 Image Alarm evaluation 
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Execute the Image Alarm function by pressing “OK” in the Signature Alarm dialog box. 
 

8. Visually check the image alarm overlay (yellow pixels) for both Errors of Omission 
(features belonging to the training class that have been left out) and Errors of Commission 
(features not belonging to the training class that have been included).  Errors of Omission can 
be solved by selecting additional training sites.  Errors of Commission must be solved by 
selecting a new training site that better represents the feature class of interest.  Remember, it 
usually takes several signatures to adequately capture the spectral variability of most land 
cover/use types. 
 

9. In order to assist you in seeing the distribution of alarm-highlighted pixels in the “2D View 
#1” display, you can use the Swipe tool. From the Home tab on the ribbon tool bar, press the 
View button. From the pop-up menu, click the Swipe button.      
   

 
 

In the Utility - Transition window that opens, set the Functional layer (i.e., the alarm 
mask) to W (Working), and set the AOI layer and the imagery layer to S (Static), as 
shown below. The default for the Swipe tool is “Left to Right” (i.e., a vertical swath of 
image overlay that can be moved left and right to “expose” the underlying image), which 
opens with the left half of the viewer showing the overlay. You move the edge of the 

1.
2. 

3.
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overlay by manipulating the slider in the “Transition Extent” sub-window (right-hand 
arrow in graphic below). 
 

 
 

 
10. When you are satisfied with your training signature (whether or not you intend to have 

additional signatures for this land cover/use type) save your signature file by clicking on 
File Save As within the “Signature Editor” window.  Name your file and save it in 
your personal folder on the server.  

 
************* 

Each time you add or delete a signature, save the signature file. 
 

************* 
You should also save the AOI file (the training polygon outlines). From the Table of 
Contents, right-click on the AOI Layer. From the drop-down menu that opens, click 
Save Layer As.  Name your AOI file and save it in your personal folder on the 
server.   
 

************* 
Each time you add or delete an AOI from the image, save the AOI file. 

 

************* 
 

If, after evaluating the Image Alarm output, you decide that a particular signature is poor, 
select and delete it from the Signature Editor window (SEW tool bar: Edit Delete).  Be 
sure to also delete the associated AOI polygon. Select one or more AOIs in the “2D View 
#1”display (use the Select tool; use shift-left-click to select multiples) and then use the 
Delete tool from Edit tool group within the Drawing tab of the ribbon interface. Save both 
the signature file and the AOI file after any deletions. 
 
 

lansing_sub.img 
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11. Now try the region-growing approach to training site selection.  This tool is especially 
helpful on very narrow cover types (like rivers) or cover types with especially irregular 
boundaries (e.g., lakes or open-grown forest stands). 

 
Make the 2D View #1 window the active layer in the Contents window. Click the 
Drawing tab in the ribbon tool bar and click the Grow tool triangle from within the Insert 
Geometry tool group. Select Growing Properties from the drop-down menu. 

 
 

 
 

 
 
Click the “surrounding” (i.e., the 9-pixel) Neighborhood icon. Set the Area constraint value 
to 10000. Set the Spectral Euclidian Distance to 15, to start. If too few pixels are 
“captured” within the region, increase this value to 20 and click the “Redo” button. Keep the 
Region Growing Properties window open and “parked” outside of the ERDAS desktop. 
 

 
 

15
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12. In the 2D View #1 window, zoom in to one of the smaller lakes in the image. Returning to 
the Drawing tab on the ribbon tool bar, click the Grow tool.  

 

 
 

In the 2D View #1 window, note that your mouse cursor is now a cross hair. Click on a 
single representative pixel within the lake.  A dotted polygon appears around the pixel group 
that met your search criteria. If the Spectral Euclidean Distance setting of 15 did not capture 
a large patch of pixels in the lake, increase the Spectral Euclidean Distance in the Region 
Growing Properties window to 20 or 25 and press the “Redo” button (bottom-left of the 
Region Growing Properties window) to see the impact of this adjustment. Your objective is 
to “capture” as many “water” pixels as possible without “growing” into any adjacent 
cover/use types by adjusting the Spectral Euclidean Distance.  Very shallow or turbid water 
that is bright should be captured as its own training polygon, since this may be confused with 
other bright land covers. 

 
When you are satisfied with the grown region in the lake, import this new AOI into 
“Signature Editor” using the “Create New Signature from AOI” button.  Again, visually 
check how well the new training signature performs by running the Image Alarm function.  
Be sure to zoom out to the full-scene view to evaluate the Alarm performance (i.e., 
visually check for errors of omission and commission). After every change, save your 
signature and AOI files. If the image in the Viewer becomes too cluttered with AOIs, you 
can temporarily “hide” them by un-checking the AOI layer in the Contents window. To see 
the AOI layer again, simply check the AOI layer in the Contents window. 

 
13. You can use shift-click to select multiple training signatures in the Signature Editor 

window.  If you have two or more signatures representing the same class, shift-click to select 
them all, change all their colors to Yellow and use Image Alarm to evaluate their collective 
(but still individual) classification power.  You can also shift-click to select multiple 
signatures and then merge them into one new signature by pressing the Merge signatures 
button, but this is not usually recommended.  If you do experiment with signature merging, 
give the merged signature a unique name and test it with Image Alarm before deleting the 
individual same-class signatures.   
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14. Continue selecting AOIs until you have a functional set of signatures for the eight required 
cover types. 

 

************ 
Be sure to save your final signature file and AOI file to your personal folder on the 
server. 

************ 
 
Supervised Classification – Maximum Likelihood Classifier 
 
15. Using the signature file that you created, make sure that unique colors have been assigned to 

each of the eight land cover/use classes (e.g., if you have three signatures to represent water, 
all three of them should be the same blue color in the Signature Editor Window).  The colors 
you select for the eight classes in the SEW will be the ones that the maximum likelihood 
classifier assigns in its output file. If you have already set your colors in the Signature Editor 
Window, proceed to Step B, below. If you have not set your colors in the Signature Editor 
Window, start with Step A, then proceed to Step B. 

 
Step A.  Click the Raster Tab on the ribbon tool bar and then click the Supervised in the 
Classification Group. Select "Signature Editor” from the pop-up menu. After a few 
moments, the Signature Editor Window (SEW) will open.  Click on the Open and Read a 
Signature File button in the SEW tool bar, navigate to your signature file and double click to 
open it. 
 

  
 

                       
 

Assign unique colors to each of the eight land cover/use classes. Remember, if you have multiple 
signatures to represent one land cover/use class, all of them should be the same color in the 
SEW.  The colors you select for the seven classes in the Signature Editor Window will be the 
ones that the maximum likelihood classifier assigns in its output file. 
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Step B.  Click the Raster Tab on the ribbon tool bar and then click the Supervised in the 
Classification Group. Select "Supervised Classification” from the pop-up menu, which will 
open the Supervised Classification window.  
 

 

   
 

- The “Input Raster File” should be automatically selected as (lansing_sub.img).  
- Select your signature file that you created for the “Input Signature File.” 
- Type in a unique file name for the “Classified File” (check to verify that this output file 

is being saved into your personal folder on the server).  
- Check “ON” the Distance File and name it (also to be saved in your personal folder on 

the server).   
- Leave the “Non-parametric Rule” set to None and the “Parametric Rule” set to 

Maximum Likelihood. Press OK. 
 
You can monitor the progress of the classification in the Process List window that opens. 
When the job is done (“Progress: 100%” and “State: Done”), press Close.  

 
 
16. To qualitatively evaluate your supervised classification for omission and commission errors 

you need to visually inspect each class independently, as it is displayed on top of the original 
image data.  
 
Step A.  Click the File tab ViewView Raster Attributes. After a few moments, the 
Raster Attribute Editor will open. Click the Open file button, then navigate to and select 
(double click) your maximum likelihood classification output file. From the Raster 
Attribute Editor tool bar, select Edit Column Properties to rearrange the columns in 
the table so that they are easier to view and work with.  The “Column Properties” dialog 
opens. 
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In the “Column Properties” window, within the “Columns” list, select Class_Names, then 
click the Top button to move it to the top. Use the Up button to move Opacity so that it is 
next under Class_Names and then move Color so that it is just under Opacity. Click OK in 
the “Column Properties” dialog to rearrange the columns in the Raster Attribute Editor (the 
Column Properties dialog closes). In the Raster Attribute Editor, click the File tab Save. 

 

 
 

Raster Attribute Editor before Column Editing 

 

  
 
       Column Properties before Column Moves            Column Properties after Column Moves 
 

 
 

Raster Attribute Editor after Column Editing 
 
 

Step B.  Click on the Open File icon in the top Imagine tool bar or right-click in the “2D 
View #1,” then select Open Raster Layer.  In either case, navigate to and select (double 
click) your maximum likelihood classification output file (from step 15B, above). 
 
In the Contents frame, right-click the classification output file and select Display Attribute 
Table from the pop-up menu. The Attribute Table for your classification file automatically 
docks across the bottom of the ERDAS Desktop display. You can “undock” it, if you wish, 
by right-click-holding from its banner and dragging it out into the viewer frame. Manually 
resize the Attribute Table for ease of use. 
 
In order to effectively evaluate each land cover/use class for errors of omission and/or 
commission, you need to view each class displayed individually on top of the image. To 
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facilitate this type of inspection, the opacity for all of the classes must be set to zero so that 
they become invisible (i.e., transparent) on top of the color composite. 

 
In the Attribute Table, right-click on the first row and click Select All from the pop-up 
menu to select all of the classes. Left-click on the column name Opacity to select this 
column for activity, then right-click on the column name Opacity to open the Column 
Options pop-up menu. Select Formula from the Column Options menu, which opens the 
Formula window.  

 
In the Formula window, click 0 from the number pad at the right.  Note that a “0” was 
placed in the Formula field. Click Apply to change all of the values in the Opacity column 
to 0 and note that the classified image “disappears” from the viewer frame. Click the Close 
button to dismiss the Formula window. 

 
 

In the Attribute Table, click on the first land cover/use Class to make it active (you may 
have to “activate” more than one row in the Attribute Table, if you had more than one 
signature representing this class). Click-hold on the color patch in the Color column for the 
selected Class(es) and change their color to Yellow (temporarily) to provide better visibility 
in the Viewer. Now, change the Opacity for the selected class to 1.   
 

 
 

Errors of omission are shown by features in the color composite that should have been 
classified as members of the particular category under inspection, but are not overlain with 
yellow. In order to see errors of commission, we need to be able to “peak” under the yellow 
overlay patches to see if the image pixels seem to be correctly classified or not.   

 
17. Click on the Swipe tool icon located within the View group under the Home tab.  Follow 

the same procedures that you did in Step 9 on page 5. 
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The selected land cover/use class, displayed in Yellow, should now appear only on the left 
half of the scene.  By manipulating the Slider Bar in the “Transition Extent Sub-Window” 
you can “cover” and “uncover” the color composite image with the classification image 
(showing only one class at the moment).  Visually check for omission and commission 
errors.   
 
Use your zoom and roam capabilities to scrutinize a number of “key” areas of “known” land 
cover/use.  You may find it necessary to compare several different color composites with the 
classified image using the Swipe tool in order to appropriately check all of your cover/use 
categories. The Swipe process will help you assess which land cover type is “underneath” 
any of the classified (colored and filled) polygons. 
 
Try to assess both errors of commission (e.g., some actual water pixels might have been 
misclassified as dark needle-leaf forests) and errors of omission (e.g., some water pixels 
might have been left out of the water class).  There is no way to isolate either of these error 
types (i.e., you can’t ask for a display of just the omission error pixels), so just be thinking 
about both error types as you scrutinize you classification. 
 
Repeat the above display and inspection procedure for all eight classes.  As you finish 
inspecting each class, don’t forget to change its color back to the mapping legend color 
you originally chose for it. 

 
 
18. After your inspection, reset the opacity of all classes to “1” and close the Attribute Table 

using the “X” in the upper-right of the table banner. Click YES, in the Verify Save on Close 
window that pops up.  
 

 
THRESHOLD (the final step of Supervised Classification). 
 
19. Thresholding is a statistical method used to refine a supervised classification by determining 

which pixels in the new thematic raster layer are most likely to be incorrectly classified 
(using the distance file that was created during the supervised classification). These 
distances occur in probability space, so larger distances are associated with lower 
probabilities of class membership.  

 
A distance threshold can be set for each class to “screen out” the pixels that probably do not 
belong to that class.  For all pixels whose distance-file values are greater than the threshold 
value that you set, the class value in the thematic raster layer is set to Zero and displayed in 
Black (i.e., these pixels become members of the “unclassified” group). 

 
From the Raster tab on the ribbon tool bar, click on Supervised button and select 
Threshold from the drop-down menu. In the Threshold window that opens after a few 
moments, click on the open file icon and select your newly created classified image and the 
associated distance image file. Click OK.  
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A window opens with the Class #, Class Name and Chi-Square values predefined, based on 
your classified image file.  From the tool bar at the top of the Threshold window, clicking 
on Histograms Compute will compute a histogram for every class in the image. 
 

 
 

From the Threshold window tool bar, click on View Select Viewer, then move your 
mouse cursor anywhere on the image displayed in the 2D View #1 window and left-click to 
select this viewer. 
 
Within the Threshold window, highlight and move the pointer  >  to the class that you 
want to examine. Click on Histograms View… to display the distance histogram for the 
selected class. Note that the pointer selects which class will have its distance histogram 
displayed (regardless of whether it is highlighted or not). 

 
Interpreting the distance histogram 
 

The brighter pixels (with the higher distance file values) are spectrally farther from the 
signature means for the classes to which they are assigned. Hence, they are more likely 
to be misclassified.  The darker pixels are spectrally nearer to the signature means for the 
classes to which they are assigned, and more likely to be classified correctly. For 
supervised classifications, the darkest pixels are usually the training samples. 
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The histogram of the distance file usually approximates a chi-square distribution. 
Normally, there are many pixels with a distance image value at or near 0, indicating 
that these pixels are likely to be classified correctly.  A histogram is generated for each 
class in the classified image file. 

 

 
The tail of the histogram represents a relatively lower number of pixels (hopefully) with 
higher values in the distance image file.  Since the Euclidean distance from these pixels to 
the class mean is large, these pixels are more likely to be incorrectly classified (i.e., their 
assigned class membership probability is very low). 
 
Thresholding allows you to “cut off the tail” of this distance histogram, eliminating the 
“low probability” pixels from each class (i.e., pixels with the highest distance values). 

 
Tips on thresholding:  

 
A.  For smooth chi-square shapes, try to find the “breakpoint” where the curve becomes 

more horizontal, and cut off the tail from this point. 
 
B.  Minor mode(s) in the curve probably indicate that the class picked up other features that 

were not represented in the signature.  You will probably want to threshold these 
features out. 

 
C.  If the histogram does not have a dominant peak near “0”, this indicates it is not a 

good class.  Polymodal (multi-peaked) distributions mean that the class is “mixed” and 
should be re-classified using new training data. 

 
D.  If the peak of the curve is significantly shifted from “0”, this indicates that the signature 

mean is off-center from the pixels it represents.  You may need to take a new signature 
and reclassify. 

 
20. In the Threshold window, click on View View Colors Default. This default setting 

will display the thresholded (i.e., eliminated) pixels in BLACK in the threshold image and 
the remaining (good) pixels in the class in the color set in the Signature Editor. 

 
Within the distance histogram for the selected class, you can move the arrow  on the X-
axis to the position where you want to threshold the distribution of pixels (keeping the pixels 
left of the threshold boundary and discarding the pixels that are right of the boundary).  
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As you move the arrow, the chi-square value is updated for the current class.  After each 
trial threshold (i.e., movement of the X-axis pointer), click on Process To Viewer in the 
Threshold window.  This causes the threshold image to be placed in the Viewer window on 
top of the classified image. NOTE that the highlighted class in the Threshold window is the 
one that will be displayed in the view, regardless of which class the pointer > is set to (the 
pointer selects the class for the distance histogram, as noted above). 
 

21. Click on the Swipe tool icon located within the View group under the Home tab.  The 
“Viewer Swipe Window” opens with default settings of a Vertical “swipe edge” located 
50% across the width of the scene. Since there are several layers in the Contents frame, you 
must manually select which one is to be the “overlay” theme. Make the threshold image 
(image name = “Functional”) the Working layer and all the other layers Static (see figure 
below). 

 
Note the 2D View #1 window: the Threshold Mask is displayed only on the left half of the 
scene.  By manipulating the Slider Bar in the “Transition Extent Sub-Window” you can 
“cover” and “uncover” the color composite image with the Threshold Mask (see screen shot 
on next page). 
 

 
 
Use your best judgment about balancing omission and commission errors to guide you in 
setting an appropriate threshold for each class – in general, minimizing commission errors is 
the preferable.  You do not have to close the distance histogram window after viewing or 
changing one class, just move the pointer > to the next class and the histogram will be 
updated for new class. 
 
Repeat this process, thresholding the histogram for each class in the Threshold window. If 
you have multiple classes to represent one land cover/use type (e.g., water1, water2 and 
water3), use shift-click to select all the members of one class and then click on Process 
To Viewer in the Threshold window.   



Geo 827     Fall 2015 16

After you have established a threshold for each class, use shift-click to select all the classes 
at once in the Threshold window, then click on Process To Viewer in the Threshold 
window.  The thresholded image, with all the unclassified pixels shown in black, is placed 
in the Viewer window on top of the classified image.  Once again, the Swipe tool can be 
used for further evaluation.  
 

22. Save the threshold result for the maximum likelihood classification to your personal 
folder on the server by clicking on Process To File in the Threshold window. Name the 
file “ML_thresh.img.” Close the Distance Histogram and Threshold windows. 

 
 

In real-world, production work, you can use the threshold mask (i.e., the unclassified pixels) 
to help inform you about the need for additional training sites. If the unclassified pixels occur 
more or less randomly across the landscape, there is not much you can do to fix the problem. 
But, if they are spatially clustered in certain places in the landscape, you can use the Swipe 
Tool to investigate what type of land cover/use they represent and delineate additional AOIs 
to represent these “new” classes. We do not have the time necessary to complete such an 
iterative process, which may take three or four iterations before an acceptable accuracy is 
achieved. Nonetheless, you now have experience with all the major steps used in the 
supervised classification processing chain.  
 
 
 

Supervised Classification – Spectral Angle Mapper 
 
 

23. Click the Raster Tab on the ribbon tool bar and then click the Supervised in the 
Classification Group. Select "Supervised Classification” from the pop-up menu, which will 
open the Supervised Classification window. 

 
- The “Input Raster File” should be automatically selected as (lansing_sub.img).  
- Select your signature file that you created for the “Input Signature File.” 
- Type in a unique file name for the “Classified File” (check to verify that this output file 

is being saved into your personal folder on the server).  
- Check “ON” the Distance File and name it (also to be saved in your personal folder on 

the server).   
- Leave the “Non-parametric Rule” set to None and the “Parametric Rule” set to 

Spectral Angle Mapper. Press OK. 
 
You can monitor the progress of the classification in the Process List window that opens. 
When the job is done (“Progress: 100%” and “State: Done”), press Close.  
 

23. To qualitatively evaluate your SAM classification for omission and commission errors you 
could visually inspect each class independently, as it is displayed on top of the original image 
data, by following steps 16 – 18, above. In the interest of time, you should move directly to 
Thresholding your SAM classification. 
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THRESHOLD (the final step of Supervised Classification). 
 

24. From the Raster tab on the ribbon tool bar, click on Supervised button and select 
Threshold from the drop-down menu. In the Threshold window that opens after a few 
moments, click on the open file icon and select your SAM classified image and the 
associated SAM distance image file. Click OK.  

 
A window opens with the Class #, Class Name and Chi-Square values predefined, based on 
your classified image file.  From the tool bar at the top of the Threshold window, clicking 
on Histograms Compute will compute a histogram for every class in the image. 
 
A window opens with the Class #, Class Name and Chi-Square values predefined, based on 
your classified image file.  From the tool bar at the top of the Threshold window, clicking 
on Histograms Compute will compute a histogram for every class in the image. Note 
that the Threshold Window shows very small “Chi-Square” values (e.g., 0.001). This is 
because the SAM distance file is not scaled in probability space like the Maximum 
Likelihood distance file was. Also note that the “Parameters:” section of the Threshold 
Window only contains a “Distance Threshold” dialog box (no “Chi-Square” dialog box). 
 

 
 

From the Threshold window tool bar, click on View Select Viewer, and then move your 
mouse cursor anywhere on the image displayed in the 2D View #1 window and left-click to 
select this viewer. 
 
Within the Threshold window, highlight and move the pointer to the class that you 
want to examine. Click on Histograms View… to display the distance histogram for the 
selected class. Note that the pointer selects which class will have its distance histogram 
displayed (regardless of whether it is highlighted or not). 
 

25. Within the Threshold window, use the up-arrow to set the “Distance Threshold” to 0.100 
and press the “Enter” key on your keyboard. Within the distance histogram for the selected 
class, you can move the arrow  on the X-axis to the position where you want to threshold 
the distribution of pixels (keeping the pixels left of the threshold boundary and discarding the 
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pixels that are right of the boundary), but this will NOT automatically update the “Distance 
Threshold” in the Threshold window. Hold down the left-mouse button while pointing at the  
arrow  on the X-axis of the distance histogram to see the value at the arrow position – 
transcribe this value into the “Distance Threshold” dialog box in the Threshold window and 
press the “Enter” key on your keyboard. Note that this updates the “Chi-Square” value for 
this class in the Threshold window. Once a new “Chi-Square” value has been entered for a 
highlighted class, click on Process To Viewer from the toolbar in the Threshold 
window.  NOTE that the highlighted class in the Threshold window is the one that will be 
displayed in the view, regardless of which class the pointer > is set to (the pointer selects the 
class for the distance histogram, as noted above). 
 

26. To inspect the omission – commission errors that this threshold has produced, use the swipe 
tool. Click on the Swipe tool icon located within the View group under the Home tab.   
 

27. Repeat this process, thresholding the histogram for each SAM class in the Threshold 
window. If you have multiple classes to represent one land cover/use type (e.g., water1, 
water2 and water3), use shift-click to highlight all the members of one class and then click 
on Process To Viewer in the Threshold window.   
 
After you have established a threshold for each class, use shift-click to select all the classes 
at once in the Threshold window, then click on Process To Viewer in the Threshold 
window.  The thresholded image, with all the unclassified pixels shown in black, is placed 
in the Viewer window on top of the classified image.  Once again, the Swipe tool can be 
used for further evaluation.  
 
Save the threshold result for the SAM classification to your personal folder on the server 
by clicking on Process To File in the Threshold window. Name the file 
“SAM_thresh.img.” 
 

28. Close the Distance Histogram and Threshold windows. Exit the ERDAS Imagine program. 
 


